Skulltag Archive
https://x1.rfc1337.net/stforum/

WADSEEKER
https://x1.rfc1337.net/stforum/viewtopic.php?f=132&t=26742
Page 1 of 2

Author:  Wh4teRh2n0 [ Sat Aug 28, 2010 2:18 am ]
Post subject:  WADSEEKER

i am having trouble with my wadseeker...i go to search for the necessary wads to play on a server...but it comes back with...


CRITICAL ERROR: No target directory specified! Aborting

can anybody help me??? :( :( :( :( :( :( :| :( :(

Author:  Remmirath [ Sat Aug 28, 2010 2:53 am ]
Post subject:  Re: WADSEEKER

Moved thread in appropriate section.

Anyway, you have to configure Wadseeker.

Go into the Doomseeker options, find the Wadseeker tab, and in the General tab, choose a directory in the field that says "Directory where Wadseeker will put wads into".

Author:  -=Dark-Assassin=- [ Sat Aug 28, 2010 2:54 am ]
Post subject:  Re: WADSEEKER

Options > Configure > Wadseeker
Then where it says 'Directory where Wadseeker will put wads into:', change the empty box below to your skulltag folder by pressing [...]

Edit: Dammit Remmirath, beat me to it.

Author:  Wh4teRh2n0 [ Sun Aug 29, 2010 12:28 am ]
Post subject:  Re: WADSEEKER

THANK YOU VWRY MUCH GUYS!!!! TRUELY APPRECIATE IT....now i feel kinda dumb but w/e

Author:  Wh4teRh2n0 [ Wed Nov 17, 2010 7:45 pm ]
Post subject:  Re: WADSEEKER

ok now i am having a different problem...i recently got the Megagame.wad file...but i am having trouble connecting to a Megagame.wad server...whenever i try to connect, it says...

Client binary cannot be opened for game:skulltag
no testing directory specified for Skulltag

anyone know the problem?? thank you :)

Author:  Xannn [ Thu Nov 18, 2010 4:35 pm ]
Post subject:  Wadseeker Strange Error

Well, I know that maybe this isn't a normal error, but after the update the wadseeker don't work propperly and doomseeker close after I launch it, again I'm using Ubuntu 9.04 and this is what the console show when I use it, of course, after the program crash and this never happened before the update:

================================
Master finished Skulltag
[23:24:44] No flag for country: PER
[23:24:51] Finished refreshing. Servers on the list: 203 (+ 0 custom). Players: 106.
./doomseeker: symbol lookup error: ./doomseeker: undefined symbol: _ZNK9Wadseeker13downloadSpeedEv

I hope it helps, see you soon, and happy fragging ^^.

PD: I didn't want to create a new Topic just for this, if someone thinks that it should be better than being just a post, just move it and... sorry for any inconvenience.

Author:  Blzut3 [ Thu Nov 18, 2010 5:09 pm ]
Post subject:  Re: WADSEEKER

Xannn, what architecture are you using (AMD64/x86-64 or x86)? If you don't know open the console and type `uname -m`.

Edit: Also, you should consider upgrading your OS. Ubuntu 9.04 went end of life October 23rd.

Author:  Xannn [ Thu Nov 18, 2010 5:51 pm ]
Post subject:  Re: WADSEEKER

Well, I'm pretty sure that I'm using a x84 architecture, this processor is an Intel Atom dual core since it is a netbook, anyway, I used that command on the console and it said "i686", Hope it helps.

Also I can create a normal off-line game and search for servers normally on Doomseeker, just the Wadseeker is having trouble running here, and before the update it worked perfectly.

I tried a clean install without luck, but I could try again. I expect your answer, but here is almost 1:00 AM (0:51 AM at this moment) and I will get in the bed soon, so maybe I would check it tomorrow.

Anyway, thanks for all ^^.

Author:  Blzut3 [ Thu Nov 18, 2010 9:28 pm ]
Post subject:  Re: WADSEEKER

Should work now. Look for an update to libwadseeker.

Author:  Xannn [ Fri Nov 19, 2010 5:46 am ]
Post subject:  Re: WADSEEKER

Thanks, I will check it as soon as I get on the PC with skulltag.

Edit: I updated the libwadseeker with the sudo apt-get upgrade libwadseeker, everything alright until I tried to run it, this is what console shows:

:~$ sudo doomseeker
[15:08:50] Starting Doomseeker. Hello World! :)
[15:08:50] Loaded plugin: "Skulltag"!
[15:08:51] Initializing IP2C database.
[15:08:52] IP2C Database read in 294 ms. Entries read: 101154
/usr/bin/doomseeker: line 3: 4349 Segmentation fault ./doomseeker

I tried using sudo apt-get remove doomseeker and then apt-get autoremove to clean files, after that I used apt-get install doomseeker-skulltag and the same error appeared when trying to run doomseeker. Now I'm really lost...

Edit 2: After some tries trying to execute it I saw that the number after line 3: changes everytime I execute the program, as far as I did, it showed "4538, 4559 and 4561". Hope this help, even when I doubt it :/.

Edit 3: Here you have the repository that I'm using, to see if that could help in any way possible: http://skulltag.net/download/files/release/deb stable multiverse

Author:  Blzut3 [ Fri Nov 19, 2010 1:12 pm ]
Post subject:  Re: WADSEEKER


Author:  Xannn [ Sat Nov 20, 2010 5:49 am ]
Post subject:  Re: WADSEEKER

Well, it's really the same error with or without sudo, that's why I didn't said that I tried with both.

I needed to make the console superuser to be able access /usr/share/doomseeker, and gdb was installed, so I did exactly what you said and this is what I got after using bt:

(gdb) bt
#0 0xb6ae8d9d in QMetaObject::indexOfSlot () from /usr/lib/libQtCore.so.4
#1 0xb6af4edc in QObject::connect () from /usr/lib/libQtCore.so.4
#2 0xb6835b42 in Protocol::Protocol () from /usr/lib/libwadseeker.so
#3 0xb68315c2 in Ftp::Ftp () from /usr/lib/libwadseeker.so
#4 0xb683ffcd in WWW::WWW () from /usr/lib/libwadseeker.so
#5 0x080e0884 in IP2C::IP2C ()
#6 0x080e3d53 in Main::initIP2C ()
#7 0x080e530c in Main::run ()
#8 0x080e54b5 in main ()
(gdb)

To evade any confussion, here is everything I did on the console, but on expoiler, so it doesn't make the post too large:



It is a bit outdate (The gdb program), but maybe it isn't important.

Hope it helps.

PD: I tried without console in superuser, and even if it display the almost the same (I don't said same because I didn't check it line for line, but it seems to be the same) it worked, so here it is what console displayed after bt command:

#0 0xb6b74d9d in QMetaObject::indexOfSlot () from /usr/lib/libQtCore.so.4
#1 0xb6b80edc in QObject::connect () from /usr/lib/libQtCore.so.4
#2 0xb68c1b42 in Protocol::Protocol () from /usr/lib/libwadseeker.so
#3 0xb68bd5c2 in Ftp::Ftp () from /usr/lib/libwadseeker.so
#4 0xb68cbfcd in WWW::WWW () from /usr/lib/libwadseeker.so
#5 0x080e0884 in IP2C::IP2C ()
#6 0x080e3d53 in Main::initIP2C ()
#7 0x080e530c in Main::run ()
#8 0x080e54b5 in main ()

And thanks for everything, sorry for my delay at posting, but that's the bad thing about timezones ^^u.

Edit: Specified what was out-date.

Author:  Blzut3 [ Sun Nov 21, 2010 12:29 am ]
Post subject:  Re: WADSEEKER

Could you try these debug binaries? Put the doomseeker binary in /usr/share/doomseeker and the libwadseeker.so in /usr/lib. Run gdb again just like before.

Author:  Xannn [ Sun Nov 21, 2010 5:03 am ]
Post subject:  Re: WADSEEKER


Author:  Blzut3 [ Sun Nov 21, 2010 10:47 am ]
Post subject:  Re: WADSEEKER


Author:  Synert [ Sun Nov 21, 2010 11:01 am ]
Post subject:  Re: WADSEEKER


Author:  Xannn [ Sun Nov 21, 2010 11:18 am ]
Post subject:  Re: WADSEEKER


Author:  Blzut3 [ Sun Nov 21, 2010 1:10 pm ]
Post subject:  Re: WADSEEKER

Perhaps you can try compiling Doomseeker yourself? Instructions can be found on the .

I don't think there will be any major problems if you continue to use the old version of Doomseeker, just be aware that you may run into bugs that have already been fixed.

Author:  Xannn [ Sun Nov 21, 2010 1:14 pm ]
Post subject:  Re: WADSEEKER

Uhm and what about the skulltag plugin for doomseeker? the new one is compatible with the old version?

Author:  Blzut3 [ Sun Nov 21, 2010 1:22 pm ]
Post subject:  Re: WADSEEKER

No, but since the protocol hasn't changed there shouldn't be any reason you can't use the old version. (In other words, as long as the server still show up you should be fine.)

Page 1 of 2 All times are UTC - 6 hours
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/