Skulltag Archive

Hosted by Dark-Assassin

The default theme was not avalible in the backup, sorry.
View unanswered posts | View active topics It is currently Sun May 09, 2021 5:33 am



Reply to topic  [ 7 posts ] 
<NO RESPONSE> but I Get Launcher Challenges! 
Author Message

Joined: Tue May 01, 2012 8:23 pm
Posts: 4
Reply with quote
Hello all, I'm still rather new to attempting hosting servers with Skulltag but this is something I was able to do before.

I'm attempting to host a coop Brutal Doom game across the net for my friends but it doesn't appear on the master server list and apparently, I'm not able to properly check if my port is open. I use Skulltag 0.98d and Doomseeker 0.7 beta-575.

I'm on a Windows 7 system with firewalls temporarily disabled.

My server uses the default port 10666. I've added a rule in my network router to forward 10666 LAN-side with 10666 Internet-side on UDP but it doesn't seem to work. (I've forwarded ports before.)

My server is set to broadcast to LAN and master and I'm also able to see launcher challenges via sv_showlauncherqueries 1 on the server UI. I'm also able join my own server and play without problem.

If I access the old server browser inside Doom itself via LAN, I can see my server. From Doomseeker's interface, I've tried adding 127.0.0.1:10666, my local network address (192.168...), and then my Internet-side address. I am able to see other servers from other hosts on the Doomseeker master list.

The localhost works and shows my server name and WADs.
The LAN works and does the same.
The Internet-side address, however, simply reads "<NO RESPONSE>".

Now the strangest part here is I'm also hosting a Ventrillo server on a custom port (3784 LAN side <=> 13338 Inet side) and I can actually ping it from outside using . My Ventrillo server displays the incoming connections from the test site. Attempting this with my Skulltag server results in the site telling me my port 10666 is closed.

Any ideas? :(


Tue May 01, 2012 8:58 pm
Profile
Developer

Joined: Wed Dec 31, 1969 6:00 pm
Posts: 1359
Location: Mental Institution
Reply with quote
And what is your problem exactly? Everything seems to work just fine from what you said.

BTW: Doomseeker 0.7 is outdated. Please update.


Wed May 02, 2012 6:10 am
Profile

Joined: Tue May 01, 2012 8:23 pm
Posts: 4
Reply with quote
Alright, Doomseeker has been to updated to 8.1.

But now I'm not sure what just happened - I'm no longer getting launcher challenges from any other IP than my own. Here's a screenshot of my problem:



First IP is localhost, second is LAN, third IP is my Hamachi - the last one is my Internet-side address. I added these addresses to the list via the Custom Servers menu. I can't ping my server via online port checking tools.

Or is this actually how it looks like if it's already working? :| If that's the case, my bad!


Wed May 02, 2012 6:38 am
Profile
Developer

Joined: Wed Dec 31, 1969 6:00 pm
Posts: 1359
Location: Mental Institution
Reply with quote
If you are getting launcher challenges from outside then it is working properly. Many routers will not redirect back to the inner network packets which try to reach the public IP but originated from that inner network, so when you are using the public IP from inside the network, the query packet is being lost on the router. The primary reason for why the Custom Servers list EXISTS is to allow users to go around this problem by adding localhost IP address to the list.

Doomseeker update certainly did not break your server visibility. Check again your router&firewall setup, see if skulltag_masterip is set to proper address and see if "Broadcast to master" is checked.

Refer to this topic: viewtopic.php?f=172&t=30603


Wed May 02, 2012 6:49 am
Profile

Joined: Tue May 01, 2012 8:23 pm
Posts: 4
Reply with quote
As it turns out, I forgot to turn my firewall exceptions on. x_x I'm now receiving launcher challenges from outside again! As long as this happens, this means my server is visible on the master list, is it?


Last edited by GVCv-Dahshor on Wed May 02, 2012 6:55 am, edited 1 time in total.



Wed May 02, 2012 6:54 am
Profile
Developer

Joined: Wed Dec 31, 1969 6:00 pm
Posts: 1359
Location: Mental Institution
Reply with quote
yes


Wed May 02, 2012 6:55 am
Profile

Joined: Tue May 01, 2012 8:23 pm
Posts: 4
Reply with quote
Alright, thanks a ton! :) Apologies for the confusion I might have caused. Now to shotty me some Imps.


Wed May 02, 2012 6:59 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 7 posts ] 

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software.